ABCelectronique : portail d'information dans le domaine de l'électronique

Merci de ne pas poster des messages en relation avec le piratage.


    Forums de Abcelectronique > Dépannage
  » variateur pwm hacheur de trotinette electrique
Identifiant Se souvenir de moi ?
Mot de passe
    Nouvelle discussion
variateur pwm hacheur de trotinette electrique

 

trestimides
trestimides ☆☆☆☆☆☆ 04/02/2010, 10h38 #1  
bonjour
ce variateur de trotinette electrique 36v 500w ne fonctionne plus (des que l'on branche les batteries, la trotinette accelere a fond en permanence)
c'est un yi-yun lbd14-1,vraissemblablement c'est un montage pwm (hacheur)
et en le demontant j'ai vu que la resistance dessinée en rouge (je l'ai dessoudée) etait totalement grillée au point d'etre illisible (sauf les couleurs des extremités:orange et marron). Celle-ci est reliée a la grosse resistance grise et au plus petit des 3 condensateurs.

a votre avis, quel peut être sa valeur?
avant d'en racheter un j'aimerais au moins essayer de changer cette resistance, on ne sait jamais...(c'est un montage qui coute quand même 40 euros!)

Merci d'avance de votre aide.
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  variateur36v.jpg
Affichages : 377
Taille :  42,7 Ko
DAUDET78
DAUDET78 ★★★★★★★ 04/02/2010, 10h57 #2  
Une résistance, ça ne grille pas tout seul. Il y a quelqu'un qui l'a suicidée .

Regarde l'état des transistors, référence ?
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Christian1980
Christian1980 ★★★☆☆☆☆ 04/02/2010, 18h33 #3  
On dirait que le petit condensateur à une tache sur le dessus comme s'il avait coulé...
roro1222
roro1222 ★★★★★★ 04/02/2010, 18h44 #4  
Daudet a raison, regarde, mais les transistors sont surement hs.
__________________
Vous recherchez un composant ??
http://stores.ebay.fr/Triacaffaire
trestimides
trestimides ☆☆☆☆☆☆ 04/02/2010, 18h45 #5  
bonsoir
alors, le petit condensateur est d'apparence normale, en vrai il n'y a aucune tache quelconque... cependant je ne sais pas comment le tester.
les gros transistors sont: 2 mpc 450 et 2 Y210DN et je ne sais pas non plus comment les tester...
ce serait sympa de me dire une methode pas trop compliquée pour les tester si il y en a une...
merci d'avance de votre aide
gipi
gipi ★★★★☆☆☆ 04/02/2010, 19h12 #6  
Bonjour,

Ci joint exemple de variateur de trotinette décortiquée
Structure et regul classique, surveillance tension batterie + courant moteur, le tout en MLI.

C'est aussi un LM339 ?

Pb de netteté, je ne vois pas très bien le circuit et en dessous de la "grosse" résistance.

La structure semble la même si ce n'est la tension et les mises en // de diodes + mosfet
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  P5034098 (Large).JPG
Affichages : 323
Taille :  149,5 Ko
Images attachées
Type de fichier : jpg variateur trotinette001.jpg (163,5 Ko, 403 affichages)
trestimides
trestimides ☆☆☆☆☆☆ 04/02/2010, 20h05 #7  
bonsoir,
effectivement,ce montage ressemble assez au mien a ceci pret que plein de composants sont en double dans le mien.
voila une photo plus precise, si quelqu'un peu me dire rapidement comment tester les transistors sommairement, ce serait sympa.
Et si l'un d'entre vous a une idée de la valeur de la resistance qui manque, ce serait vraiment utile aussi.
merci encore de votre aide
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  variateur36v2.jpg
Affichages : 276
Taille :  210,5 Ko
gipi
gipi ★★★★☆☆☆ 04/02/2010, 20h09 #8  
Pour tester les mos en attendant la suite
http://www.abcelectronique.com/foru...ead.php?t=24493
gipi
gipi ★★★★☆☆☆ 04/02/2010, 20h15 #9  
Photo plus nette ? côté circuit imprimé pour suivre les pistes.
N'écrit pas dessus
trestimides
trestimides ☆☆☆☆☆☆ 04/02/2010, 20h22 #10  
voici la photo des pistes, et merci pour le lien.
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  variateur36v3.jpg
Affichages : 259
Taille :  197,7 Ko
gipi
gipi ★★★★☆☆☆ 04/02/2010, 20h52 #11  
la résistance avec le petit condo sert de tampon pour le driver du MOS (les 2 petits transistors)
la valeur n'est pas critique mais doit rester faible, 3.3 Ohm? (si débute par orange) ou 10 Ohm ? (si débute par marron)
T1 (petit transistor) semble avoir souffert aussi
Si elle a grillé => trop de courant => voir petits transistors + MOS
trestimides
trestimides ☆☆☆☆☆☆ 05/02/2010, 08h51 #12  
effectivemement gipi, dans ton montage "p50...jpg" qui ressemble beaucoup au mien, la resistance presdes 2 petitstransistorset du MOS est une 3.3 ohm, je me dis qu'il serait peut etre pas idiot d'en mettre une identique.
j'aimerais bien tester les condos, les petit transistors et les MOS mais meme en regardant divers explications, aucune n'est bien realisable avec mon multimetre basique, et je ne sais jamais si il est imperatif de dessouder les composants pour les tester...
trestimides
trestimides ☆☆☆☆☆☆ 05/02/2010, 08h55 #13  
ah non, il semble que la resistance de ton montage soit plutot une 32 ohms et non une 3.3 ohms, du coup je ne sais plus...
gipi
gipi ★★★★☆☆☆ 05/02/2010, 13h49 #14  
Bonjour,

Sur ma photo, les composants ne sont pas à la même place que la tienne. Par ailleurs, ce tampon n'existe pas sur mon variateur (250W).
Il n'est là que pour réaliser un filtrage de l'alimentation.
Pour les transistors et diodes, oui il faut les dessouder pour les tester. Un multimetre en fonction diode suffit pour au moins dégrossir s'ils ne sont pas HS.

T6 et T7 sont des diodes.
LEs ref ne me disent rien : à dessouder + photos sur les ref

Ci-joint positions des diodes et MOS
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  position diodes.jpg
Affichages : 117
Taille :  335,1 Ko Cliquez sur l'image pour la voir en taille réelle

Nom :  postions MOS DIODES.jpg
Affichages : 111
Taille :  328,5 Ko
trestimides
trestimides ☆☆☆☆☆☆ 05/02/2010, 16h00 #15  
apparement, une resistance ne peut finir par la couleur orange, donc l'orange devait etre la premiere couleur, peut etre une 3.3 ohms?
je ne trouve plus ma pompe a dessouder, des que j'ai dessoudé ces composants, je te met les photos.
merci pour le temps que tu passes à m'aider depuis le debut.
trestimides
trestimides ☆☆☆☆☆☆ 13/02/2010, 16h51 #16  
bonjour
j'ai enfin dessoudé les diodes et mos
voici un de 2 mos en photo, il semble que ce soit les memes mais ils ont été limés!!!
j'ai testé les diodes, elle ont l'air bonnes
j'ai tenté de tester les mos mais c##########Pas de SMS et les mots en entier dans ce forum########## moins facile pour moi, meme avec le lien que tu m'as donné gipi, par contre ce qui est sur c'est que les deux ne reagissent pas du tout pareil, un des deux est systematiquement passant entre la patte du milieu et n'importe quel patte des cotés, et peu importe le sens dans lequel je met les broches du testeur. L'autre a l'air de reagir differement suivant l'ordre et le sens des broches, mais il ne reagit pas exactement comme il semblerait devoir le faire si je suis le truc ke##########Pas de SMS et les mots en entier dans ce forum########## tu m'as donné.
si les mos te disent kelk##########Pas de SMS et les mots en entier dans ce forum########## ##########Pas de SMS et les mots en entier dans ce forum########## chose... j'ai cherché sur le net mais rien ne correspond a ce que je peux lire dessus.
merci de ton aide

##########Pas de SMS et les mots en entier dans ce forum##########
##########Pas de SMS et les mots en entier dans ce forum##########
##########Pas de SMS et les mots en entier dans ce forum##########
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  mos.jpg
Affichages : 130
Taille :  92,5 Ko

Dernière modification par Fas54 13/02/2010 à 18h29. Motif: ##########Pas de SMS et les mots en entier dans ce forum##########
roro1222
roro1222 ★★★★★★ 13/02/2010, 17h11 #17  
Celui qui est tout le temps passant, est mort donc a changer.
__________________
Vous recherchez un composant ??
http://stores.ebay.fr/Triacaffaire
juju6030
juju6030 ★★★★★☆☆ 13/02/2010, 18h21 #18  
comme la dit roro
tu peut changer le mos
trestimides
trestimides ☆☆☆☆☆☆ 14/02/2010, 16h34 #19  
merci,
vu la tete des mos, et ce qu'il reste des references, je n'arrive pas a trouver sur le net, quelqu'un a une idée du mos que je pourrais mettre a la place?
je rappelle que cet un variateur 36v 500w...
merci de votre aide
trestimides
trestimides ☆☆☆☆☆☆ 15/02/2010, 10h06 #20  
rebonjour
j'ai commandé un nouveau controleur sensé etre le meme, mais biensur il est different a l'interieur...
je vous joint les photos ,des fois que cela puisse vous aider à m'aider ;)
les mos sont des : T430 BN7U9P mais je n'ai rien vu sur le net y correspondant, en plus je trouve que certaines soudures sont immondes, même moi je pense faire mieux!!
je cherche toujours la valeur de la resistance qui avait cramée, si quelqu'un a une idée, je suis preneur...
merci de votre aide
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  2eme variateur36v.jpg
Affichages : 125
Taille :  277,8 Ko
trestimides
trestimides ☆☆☆☆☆☆ 15/02/2010, 10h08 #21  
autre chose aussi, quelqu'un pourrait me dire si il voit une difference notoire entre les deux? le premier est censé gérer au mieux les batteries, couper en cas d'affaiblissement trop important des batteries pour ne pas les endomager, celui-ci fera-t-il pareil a votre avis?
merci
gipi
gipi ★★★★☆☆☆ 15/02/2010, 12h57 #22  
Bonjour,

A priori, semble être la même structure à la sauce CMS.
Fais une photo zoom sur le CI pour la ref
gipi
gipi ★★★★☆☆☆ 15/02/2010, 13h11 #23  
Pour le mos HS et limé, essayer de mouiller le dessus du composant et voir en lumière rasante. Le mieux étant d'essayer de lire avec une lampe loupe.
gipi
gipi ★★★★☆☆☆ 15/02/2010, 13h13 #24  
Pour la ref des nouveaux MOS => photo pour essayer de voir un quelconque symbole de fabricant
trestimides
trestimides ☆☆☆☆☆☆ 15/02/2010, 14h08 #25  
Voila la patine en recto verso ainsi que les nouveaux mos.
Pour les anciens, impossible de dechiffrer...
Impossible aussi de faire une photo des CI suffisement nette alors voila ce qu'il y a d'ecrit:
sur l'ancien:3BAYCJM LM339N
sur le nouveau qui est bien plus petit: ND03631 avec le meme symbole que sur les ancien mos ,c'est a dire "ST"

merci de votre aide!
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  2eme variateur36v.jpg
Affichages : 155
Taille :  277,8 Ko Cliquez sur l'image pour la voir en taille réelle

Nom :  2eme variateur36v2.jpg
Affichages : 132
Taille :  172,5 Ko Cliquez sur l'image pour la voir en taille réelle

Nom :  Dsci1919.jpg
Affichages : 185
Taille :  78,0 Ko
gipi
gipi ★★★★☆☆☆ 15/02/2010, 16h56 #26  
La structure est légèrement différente. R18/CD3 réalise la cellule de filtrage et R17 limite le courant pour la zener (diode rouge)
Pour le reste, le driver de MOS est le même.

Sur le premier variateur, tu peux remplacer ta résistance par une trentaine d'ohms. Par contre changer le MOS HS et les 2 petits transistors du driver. Tu peux le faire fonctionner avec la trottinette en l'air (à vide), pour voir si tout va bien avec un seul mos.

Pour trouver un remplaçant pour le MOS : eN se basant sur le mien, vouloir doubler la puissance, c'est doubler le courant soit avoir une résistance de mesure du courant divisée par 2 (2 straps dans ton cas) ce qui permet de garder le même seuil avec le comparateur. Donc doubler le courant, c'est doubler les MOS, tu peux alors les remplacer par 2*STP60NF06

Dans les 2 cas (pas revu en détail pour le 2eme) la surveillance de la batterie est présente. Pour moi, elle coupe pour une tension batterie de 19V (vérifié avec le schéma).

JE ne reconnais pas le symbole du MOS sur ton nouveau variateur. Peut etre quelqu'un d'autre le connait ??
trestimides
trestimides ☆☆☆☆☆☆ 15/02/2010, 17h21 #27  
merci beaucoup gipi pour ton aide precieuse!
donc:
je met une resistance d'une trentaine d'ohms.
je peux tester si ça marche en ne laissant que le mos qui fonctionne,
- oui= je remplace les mos par 2 STP60NF06
- non= je remplace les 2 petits transistors puis si ça marche, les mos
c'est bien ça?
en tout cas, merci pour tes conseils et le temps que tu as passé!
gipi
gipi ★★★★☆☆☆ 15/02/2010, 17h42 #28  
Posté par trestimides

je peux tester si ça marche en ne laissant que le mos qui fonctionne,



Faire en plusieurs temps
1/ Remplacer la résistance
2/Retirer les 2 MOS + petits transistors
3/ Rebrancher sur trotinette en isolant le variateur
4/ Faire essai et mesure avec voltmètre sur DC entre pin 1 et masse du CI LM339. LA tension doit varier suivant l'accélérateur. Si ok, signal de commande des mos ok
5/ Si commande ok. Changer les petits transistors
6/ Un essai possible (à vide) avec le mos qui reste et semble bon. Mais comme tu dois en changer un, mieux vaut mettre un neuf STP60NF06
trestimides
trestimides ☆☆☆☆☆☆ 15/02/2010, 22h24 #29  
ok, merci je vais essayer
reste plus qu'a trouver quelle est la pin1 et la masse du CI, je vais regarder sur le net.
merci encore, je te tiens au courant.
trestimides
trestimides ☆☆☆☆☆☆ 15/02/2010, 22h33 #30  
si je ne me trompe pas, c'est la pin 1 et 12, comme sur la photo jointe, non?
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  variateur36v4.jpg
Affichages : 132
Taille :  212,4 Ko
trestimides
trestimides ☆☆☆☆☆☆ 15/02/2010, 22h50 #31  
derniere question, sur le net, existe-t-il un site ou on peut trouver seulement quelques composants et avec des frais de ports honnete (8 euros pour une resistance, c vraiment exagéré!) car pres de chez moi, il n'existe plus de revendeurs...
gipi
gipi ★★★★☆☆☆ 16/02/2010, 07h13 #32  
Posté par trestimides

si je ne me trompe pas, c'est la pin 1 et 12, comme sur la photo jointe, non?



Oui c'est cela.
Pour la masse, tu peux aussi prendre l'extrémité des straps, qui évite les accidents au cas ou la pointe glisse
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  Masse.jpg
Affichages : 89
Taille :  184,2 Ko
gipi
gipi ★★★★☆☆☆ 16/02/2010, 07h19 #33  
Posté par trestimides

derniere question, sur le net, existe-t-il un site ou on peut trouver seulement quelques composants et avec des frais de ports honnete (8 euros pour une resistance, c vraiment exagéré!) car pres de chez moi, il n'existe plus de revendeurs...



Hélas non, port + frais emballage.
Pour tes petits transistors, tu as peut etre quelques composants d'avance (ou recup) qui pourraient convenir.
Si tu as, donne les ref pour voir. Je pense qu'un TUN et TUP (Transistor universel NPN et PNP - si je me souviens bien) devraient convenir
trestimides
trestimides ☆☆☆☆☆☆ 16/02/2010, 08h09 #34  
ok, je vais regarder ça, merci encore, je te tiens au courant!
trestimides
trestimides ☆☆☆☆☆☆ 16/02/2010, 08h42 #35  
Je viens de trouver 2 petits transistors C945 016, penses-tu que ça puisse aller?
gipi
gipi ★★★★☆☆☆ 16/02/2010, 09h22 #36  
C'est un NPN qui devrait aller. Faudrait la ref de celui d'origine pour voir si les brochages sont compatibles
http://www.digchip.com/datasheets/p.../606/2SC945.php

Reste à trouver le PNP en recup
trestimides
trestimides ☆☆☆☆☆☆ 16/02/2010, 11h17 #37  
ok, au fait, pourquoi faut-il absolument les changer? peut ne sont-il pas morts?
gipi
gipi ★★★★☆☆☆ 16/02/2010, 11h33 #38  
Oui c'est vrai mais tu n'as pas l'air à l'aise avec les tests de transistors. Et vu le prix .... De plus s'il sont HS, ta résistance sera détruite à nouveau
Vu le MOS HS, le petit transistor (sur le driver) du haut doit etre détruit

Si tu veux essayer de les tester, donne moi les ref, je t'indiquerai un test grossier pour voir si HS.
trestimides
trestimides ☆☆☆☆☆☆ 16/02/2010, 13h42 #39  
Non, tu as raison, tester les grosses diodes ok, mais les transistors c'est moins evident et j'ai eu du mal avec les mosfet alors autant les changer tout de suite.
Merci encore, reste plus qu'à trouver un site pour commander tout ça avec moins de 18 euros de frais de port (ça me fait halluciner ça !!)
trestimides
trestimides ☆☆☆☆☆☆ 16/02/2010, 14h15 #40  
une question de plus! :
les mos STP60NF06, en regardant les caracteristiques, je constate que ce sont des 60V 60A NPN avec boitier TO220 mais chez gotronic ils n'en ont pas, je peux remplacer par n'importe quel autre mos ayant les memes caracteristiques ou s'en rapprochant?
et puis-je faire ça avec chaque composants?
gipi
gipi ★★★★☆☆☆ 16/02/2010, 15h20 #41  
C'est un Mos Canal N (les NPN c'est pour les transistors bipolaires).

Bon y a un hic auquel je n'étais pas confronté avec mon variateur alimenté en 24V.
Ta résistance qui a été détruite servait aussi à faire chuter la tension des batteries (36V) pour attaquer les grilles des MOS. Ils ne supportent pas plus d'un 20ene de V. Le calcul de la chute de tension correspondante (courant moyen) tient compte de plusieurs paramètres (fréquence de découpage, capacité de grilles, résistances de grilles). Je comprends mieux pourquoi cela a pu claquer. Si tu veux garder le même principe, il faudrait faire quelques mesures en fonctionnement.

Tes 36V, c'est 3 batteries de 12V ? Si oui, je te propose de ramener le +12V (la batterie la plus près du moins du montage) à la borne de ta résistance, l'autre borne restant connectée à la petite capacité. => un fil volant en plus + isolation.

Y a d'autre solution mais c'est la plus simple pour toi.

Pour des équivalences de MOS, il y en a "à la pelle" surtout pour une utilisation classique. Pour le calibre en courant, il faudrait les valeurs des straps (fil résistif) pour estimer la valeur de la limitation de courant. Je n'ai pas mon variateur sous la main mais je peux faire les mesures la semaine prochaine si besoin. L'idée était de prendre le même calibre que celui pour une 250W puisque tu as 2 MOS en parallèle.

As tu testé le LM339 (mesure entre pin 1 et masse) ?
gipi
gipi ★★★★☆☆☆ 17/02/2010, 07h35 #42  
Autant pour moi, ne tiens pas compte de la modif au post #41.
J'ai oublié les résistances (diviseur) devant les transistors. Les mos sont donc commandés avec environ la moitié de la tension batterie.

Si la commande (LML339) est ok, tout devrait rentrer dans l'ordre.
trestimides
trestimides ☆☆☆☆☆☆ 17/02/2010, 09h16 #43  
OUF!!
car en fait j'avais pas super bien compris ton post 41! ça commençais a devenir un peu trop lourd comme manip pour un novice comme moi!
je te tiens au courant
thrcarnet
thrcarnet ☆☆☆☆☆☆ 26/11/2011, 14h19 #44  
Bonjour,

Pas de nouvelle, j'ai le même soucis avec un variateur 250W
Merci
A+